Data Entry from Excel to Online Form

Hi AKB Team,

Please refer to attached images below. I’m working on a demo to showcase RPA process for data entry from Excel input to Online Form output. There seems to be errors regarding variable type conversion. Is there any way to resolve this?

Hi @akmalharith
Try using “For Each Row” please.


Then let us know if it solves your problem.

The errors still the same with For Each Row.

I’m uploading the Template of the demo, would you please look into it and kindly help provide workaround if the errors could not be resolved.

FormFillingonWeb - (12.2 KB)

Hi @akmalharith
Please check the project I sent you, I used 2 ways of iterating the DataTable, the data is printed in the Ouput section.

FormFillingonWeb - (13.3 KB)

Then let me know if it works.
Best regards

Hi @ThanhThunder

May I ask if you could kindly provide a simple template to Excel Read Range and Write the data to Online Form?

I think the project provided doesn’t really align with the process I’m working on, or at least I don’t know how to apply them without the aforementioned errors.

Thank you.

Hi @akmalharith

I modified the original Workflow you posted so that it can read the data in the Excel file and then import it into the form. Please check again and let me know the result.
FormFillingonWeb - (12.5 KB)

Best regards!

Hi @ThanhThunder

I run the script, but it stops doing anything after opening the online form.

For some reason, “Pick Target Element” in Type Into (NB) cannot recognize the text box on the online form.

Hi @akmalharith

That script runs fine on my machine.
Please help me check by following these steps:

  1. Create a simple Workflow using only TypeInto (NB) to type in a field on the form. Make sure to delete all files (.log) in %LocalAppData%/akaBot/Logs folder before running Workflow.

  1. If there is still an error that makes it impossible to type in the field, please:
    • Take a picture of the error message
    • Send me the files (.log) in the folder %LocalAppData%/akaBot/Logs
    • Send me the version of akaBotStudio and the version of the NativeBrowser package you are using

Best regards!

Hi @ThanhThunder

I think I managed to pinpoint the issue, looking back at my older script where the TypeInto (NB) is functional, I noticed the older script is using NB Package version, whereas the newer script is using version 5.0.0.

Downgrading the package on the newer script seems to solve the issue.

Thank you.

1 Like